cancel
Showing results for 
Search instead for 
Did you mean: 

Backup and Recovery Process in Postgres

Adventurer

Backup and Recovery Process in Postgres

Hi,

 

Can anyone please help on how to schedule a daily CRON backup (via BART) in our Postgres PRODUCTION server.

2 types of backup will be running.

 

i. Daily Incremental backup.

ii.Weekly Full backup.

 

Thanks,

Sandeep

 

4 REPLIES
Adventurer

Re: Backup and Recovery Process in Postgres

Can anyone update

Community Manager

Re: Backup and Recovery Process in Postgres

Hi Sandeep,

 

In 2.0, you can refer to the documentation in Section 4 (which covers how to define global parameters and override parameters for retention policies), as well as Section 5.2.x (which covers how these policies as applied to your base backups might affect the incrementals).  Cron jobs can then be constructed based off of your final BART .conf file resulting from these settings.  The latest documentation for Version 2.0 is available on the website here: http://get.enterprisedb.com/docs/EDB_Postgres_Backup_and_Recovery_Guide_v2.0.pdf.

 

Thanks and Best Regards,

 

Jamie 

Highlighted
Adventurer

Re: Backup and Recovery Process in Postgres

I'm getting the below error message when trying to install BART on my system:

 

[root@edb newfolder]# yum install edb-bart20
Loaded plugins: product-id, refresh-packagekit, security, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package edb-bart20.x86_64 0:2.0.0-1.rhel6 will be installed
--> Processing Dependency: libboost_timer-mt.so.1.48.0()(64bit) for package: edb-bart20-2.0.0-1.rhel6.x86_64
--> Processing Dependency: libboost_thread-mt.so.1.48.0()(64bit) for package: edb-bart20-2.0.0-1.rhel6.x86_64
--> Processing Dependency: libboost_system-mt.so.1.48.0()(64bit) for package: edb-bart20-2.0.0-1.rhel6.x86_64
--> Processing Dependency: libboost_serialization-mt.so.1.48.0()(64bit) for package: edb-bart20-2.0.0-1.rhel6.x86_64
--> Processing Dependency: libboost_iostreams-mt.so.1.48.0()(64bit) for package: edb-bart20-2.0.0-1.rhel6.x86_64
--> Processing Dependency: libboost_filesystem-mt.so.1.48.0()(64bit) for package: edb-bart20-2.0.0-1.rhel6.x86_64
--> Processing Dependency: libboost_chrono-mt.so.1.48.0()(64bit) for package: edb-bart20-2.0.0-1.rhel6.x86_64
--> Finished Dependency Resolution
Error: Package: edb-bart20-2.0.0-1.rhel6.x86_64 (enterprisedb-tools)
Requires: libboost_timer-mt.so.1.48.0()(64bit)
Error: Package: edb-bart20-2.0.0-1.rhel6.x86_64 (enterprisedb-tools)
Requires: libboost_filesystem-mt.so.1.48.0()(64bit)
Error: Package: edb-bart20-2.0.0-1.rhel6.x86_64 (enterprisedb-tools)
Requires: libboost_system-mt.so.1.48.0()(64bit)
Error: Package: edb-bart20-2.0.0-1.rhel6.x86_64 (enterprisedb-tools)
Requires: libboost_thread-mt.so.1.48.0()(64bit)
Error: Package: edb-bart20-2.0.0-1.rhel6.x86_64 (enterprisedb-tools)
Requires: libboost_chrono-mt.so.1.48.0()(64bit)
Error: Package: edb-bart20-2.0.0-1.rhel6.x86_64 (enterprisedb-tools)
Requires: libboost_iostreams-mt.so.1.48.0()(64bit)
Error: Package: edb-bart20-2.0.0-1.rhel6.x86_64 (enterprisedb-tools)
Requires: libboost_serialization-mt.so.1.48.0()(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
[root@edb newfolder]#

 

 

Where can I get these dependent RPMs. When I'm installing one of them from google, it's again coming with another set of dependent RPMs.

[edbas96]
name=EnterpriseDB Advanced Server 9.6 $releasever - $basearch
baseurl=http://***-us:d*****@yum.enterprisedb.com/9.6/redhat/rhel-$releasever-$basearch
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/ENTERPRISEDB-GPG-KEY

[ppas95]
name=Postgres Plus Advanced Server 9.5 $releasever - $basearch
baseurl=http://***-us:d*****@yum.enterprisedb.com/9.5/redhat/rhel-$releasever-$basearch
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/ENTERPRISEDB-GPG-KEY

[enterprisedb-dependencies]
name=EnterpriseDB Dependencies $releasever - $basearch
baseurl=http://***-us:d*****@yum.enterprisedb.com/dependencies/redhat/rhel-$releasever-$basearch
enabled=1
gpgcheck=1.

 

YUM is configured properly for EDB. Can you please help me here.

 

Thanks,

Sandeep

Community Manager

Re: Backup and Recovery Process in Postgres

Hi,

 

EPEL repository is required to BART 2.0 for Boost 1.48 for RHEL6/CentOS6.

Have you tried executing the following to get the EPEL package:

yum install epel-release*

Please confirm if you have followed the steps on Page 25 of the BART document at the following link:

http://get.enterprisedb.com/docs/EDB_Postgres_Backup_and_Recovery_Guide_v2.0.pdf

 

Regards,

Deepanshu