cancel
Showing results for 
Search instead for 
Did you mean: 

PostGIS Support

Adventurer

PostGIS Support

Hi,

I'm curious if i can install PostGIS open source version directly with EDB Postgres or if there is a special PostGIS distributed by EDB.  I'd like to do some geo spatial data type testing.  

 

Thanks

Tags (1)
4 REPLIES
Adventurer

Re: PostGIS Support

I found this link

https://community.postgresrocks.net/t5/Postgres-Gems/PostGIS-Quickstart-EPAS-9-5-on-RHEL-CentOS-7/ba...

but i'm being told ppas95-postgis is not there.  Anyone??

EDB Team Member

Re: PostGIS Support

Hi Team,

We package Postgis with EPAS. So the one which we package with EPAS is compatible with it and we only recommend to use that Postgis with EPAS rather than the community one. When you install EPAS, it also installs stack builder plus with it which you can use to download the compatible version of Postgis which is shipped with EPAS 9.5. Currently we ship Postgis 2.1.8 with EPAS 9.5 which you can install in your environment to test.

 

Regards ,

Swagata 

 

Adventurer

Re: PostGIS Support

Hi,

Thanks for the quick response.  

 

I cannot get stackbuilder to work, i'm getting a invalid cert.  

 

I did follow the links instruction and was able to install PostGIS, but i'm running advanced server 9.6.  Once the installation is complete 9.6 no longer works.  I'm getting

==== AUTHENTICATION COMPLETE ===

Job for edb-as-9.6.service failed because the control process exited with error code. See "systemctl status edb-as-9.6.service" and "journalctl -xe" for details.

[enterprisedb@master ~]$ systemctl status edb-as-9.6.service

edb-as-9.6.service - EDB Postgres Advanced Server 9.6

   Loaded: loaded (/usr/lib/systemd/system/edb-as-9.6.service; enabled; vendor preset: disabled)

   Active: failed (Result: exit-code) since Wed 2017-10-18 11:32:47 MDT; 46s ago

  Process: 2263 ExecStartPre=/usr/edb/as9.6/bin/edb-as-96-check-db-dir ${PGDATA} (code=exited, status=1/FAILURE)

[enterprisedb@master ~]$ systemctl start edb-as-9.6

==== AUTHENTICATING FOR org.freedesktop.systemd1.manage-units ===

Authentication is required to manage system services or units.

Authenticating as: rkenning

Password:

==== AUTHENTICATION COMPLETE ===

Job for edb-as-9.6.service failed because the control process exited with error code. See "systemctl status edb-as-9.6.service" and "journalctl -xe" for details.

 

Is PostGIS not compatabile with 9.6? should i move the DB back to 9.5?

 

Thanks again

Highlighted
EDB Team Member

Re: PostGIS Support

Hi montereyray ,

PostGIS is compatible with PostgreSQL 9.0 and above. Could you please try once starting the service as a root user to and let us know if it works.

 

Thanks ,

Swagata