cancel
Showing results for 
Search instead for 
Did you mean: 

pem upgrade

Highlighted
Level 3 Adventurer

pem upgrade

is it possible to do an inplace upgrade from pem-server-7.0.0-1-linux-x64.run to pem-server-7.1.0-1-linux-x64.run, After installing i notice that i had installed the 7.1 pem agent, however my pem server is at 7.1.

 

regards

 

Matt

Tags (1)
7 REPLIES
EDB Team Member

Re: pem upgrade

Hi MattGorham,

 

Hope you are doing good.

Yes it is possible to an inplace upgrade from PEM 7.0 to PEM 7.1.

 

Thanks,

Swagata 

Level 3 Adventurer

Re: pem upgrade

could you point me to the instructions to do the upgrade

 

thanks in advance

 

matt

Level 3 Adventurer

Re: pem upgrade

hi @MattGorham

 

just download and install PEM 7.1 version it will replace the previous version

 

i did that with 7.1 to 7.2 

 

regards

Level 3 Adventurer

Re: pem upgrade

I will give it a go,  thanks

Level 3 Adventurer

Re: pem upgrade

attempted upgrade,  got the following error,

 

Error: There has been an error.
Error reading INI file /opt/edb/pem/agent/etc/agent.cfg

 

checked and noticed that the agent.cfg file is not found in that location.

 

it is located here,  -  /usr/pem/agent/etc/agent.cfg

 

How would i correct this and proceed with upgrade?

 

Level 3 Adventurer

Re: pem upgrade

Are you sure that is the PEM directory (/opt/edb/pem/agent/etc/agent.cfg) or you installed in other directory?

see the doc about update, only said that the new version replace the old :

https://www.enterprisedb.com/docs/en/7.1/pemupgrade/upgrade_and_migration_guide.1.06.html#

 

https://www.enterprisedb.com/docs/en/7.1/peminstguide/installation_guide.1.10.html#

 

in my server the directory and file exist:

pem_directory.png

 

 

regards

Moderator

Re: pem upgrade

Hi Matt,

 

I'm assuming your existing version was installed via our Yum repo, and now you're trying to upgrade by runnning the *.run installer.  If that's the case, try running the installer with the --prefix <prefix> flag.  It defaults to /opt/edb/pem, which is probably why you're encountering the issue.

 

Hope that helps!